yum-builddep…

Bumping mapnik to the latest version today and needed to install build dependencies on my new F-13 box after getting:

[chris@bigchunk rpmbuild]$ rpmbuild -ba SPECS/mapnik.spec
error: Failed build dependencies:
postgresql-devel is needed by mapnik-0.7.1-1.fc13.x86_64
gdal-devel is needed by mapnik-0.7.1-1.fc13.x86_64
proj-devel is needed by mapnik-0.7.1-1.fc13.x86_64
agg-devel is needed by mapnik-0.7.1-1.fc13.x86_64
scons is needed by mapnik-0.7.1-1.fc13.x86_64
gcc-c++ is needed by mapnik-0.7.1-1.fc13.x86_64
libtool-ltdl-devel is needed by mapnik-0.7.1-1.fc13.x86_64
qt-devel > 4.3 is needed by mapnik-0.7.1-1.fc13.x86_64
libxml2-devel is needed by mapnik-0.7.1-1.fc13.x86_64
boost-devel is needed by mapnik-0.7.1-1.fc13.x86_64
libicu-devel is needed by mapnik-0.7.1-1.fc13.x86_64
libtiff-devel is needed by mapnik-0.7.1-1.fc13.x86_64
libjpeg-devel is needed by mapnik-0.7.1-1.fc13.x86_64
cairomm-devel is needed by mapnik-0.7.1-1.fc13.x86_64

Thanks to Rathann on IRC:

[chris@bigchunk rpmbuild]$ sudo yum-builddep mapnik

and I’m done. 🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s